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Legal information 
Use of application examples 

Application examples illustrate the solution of automation tasks through an interaction of several 
components in the form of text, graphics and/or software modules. The application examples are 
a free service by Siemens AG and/or a subsidiary of Siemens AG (“Siemens”). They are non-
binding and make no claim to completeness or functionality regarding configuration and 
equipment. The application examples merely offer help with typical tasks; they do not constitute 
customer-specific solutions. You yourself are responsible for the proper and safe operation of the 
products in accordance with applicable regulations and must also check the function of the 
respective application example and customize it for your system. 
Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the 
application examples used by technically trained personnel. Any change to the application 
examples is your responsibility. Sharing the application examples with third parties or copying the 
application examples or excerpts thereof is permitted only in combination with your own products. 
The application examples are not required to undergo the customary tests and quality inspections 
of a chargeable product; they may have functional and performance defects as well as errors. It is 
your responsibility to use them in such a manner that any malfunctions that may occur do not 
result in property damage or injury to persons. 
 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without 
limitation, liability for the usability, availability, completeness and freedom from defects of the 
application examples as well as for related information, configuration and performance data and 
any damage caused thereby. This shall not apply in cases of mandatory liability, for example 
under the German Product Liability Act, or in cases of intent, gross negligence, or culpable loss of 
life, bodily injury or damage to health, non-compliance with a guarantee, fraudulent 
non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for 
damages arising from a breach of material contractual obligations shall however be limited to the 
foreseeable damage typical of the type of agreement, unless liability arises from intent or gross 
negligence or is based on loss of life, bodily injury or damage to health. The foregoing provisions 
do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens 
against existing or future claims of third parties in this connection except where Siemens is 
mandatorily liable. 
By using the application examples you acknowledge that Siemens cannot be held liable for any 
damage beyond the liability provisions described. 
 

Other information 
Siemens reserves the right to make changes to the application examples at any time without 
notice. In case of discrepancies between the suggestions in the application examples and other 
Siemens publications such as catalogs, the content of the other documentation shall have 
precedence.  
The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  
 

Security information 
Siemens provides products and solutions with industrial security functions that support the secure 
operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. 
Siemens’ products and solutions constitute one element of such a concept. 
Customers are responsible for preventing unauthorized access to their plants, systems, machines 
and networks. Such systems, machines and components should only be connected to an 
enterprise network or the Internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.  
For additional information on industrial security measures that may be implemented, please visit 
https://www.siemens.com/industrialsecurity. 
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats. 

To stay informed about product updates, subscribe to the Siemens Industrial 
Security RSS Feed at: https://www.siemens.com/industrialsecurity. 

https://support.industry.siemens.com/
https://www.siemens.com/industrialsecurity
https://www.siemens.com/industrialsecurity
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1 Introduction 

1.1 Overview 

The integrated functions of a LOGO! 8 offer many additional options for solving 
automation tasks quickly and easily. 

With LOGO!, readymade function blocks support project creation, e.g. a weekly 
time switch, a pulse generator, an astronomical clock, a seasonal time switch, a 
stopwatch, and simple logic gates. 

With LOGO! 8.2 and higher, the integrated web server of LOGO! 8 additionally 
offers you the option of creating user-defined web pages for clear operator control 
and monitoring.1 This allows you to call and control functions via the network. 

This application example offers you a finished circuit for LOGO! 8 for controlling a 
sliding gate using a reversing contactor circuit. 

 

Figure 1-1 

LOGO! 8

 

 

Advantages of LOGO! versus a conventional electrical installation 

Simple integration of LOGO! 8 offers you the following benefits: 

• Supplementing the switching program with additional tasks 

• An integrated web server for visualization and control 

• Control and parameterization by means of the LOGO! display 

• Integrating the LOGO! signals into a KNX system2 

Target group 

This application example is aimed at specialist electrical installation staff.  

                                                   
1 With LOGO! 8.2 and higher, you create user-defined web pages using the LOGO! Web Editor. 
However, this is not covered in this application example. 
2 When using the LOGO! CMK2000 communications module 
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1.2 Mode of operation 

LOGO! is used to control power contactors for clockwise or counterclockwise 
rotation of a three-phase motor. The motor moves a sliding gate. Mutual locking of 
the power contactors is carried out in the LOGO! switching program (reversing 
contactor circuit). 

To minimize the risk of accidents, a signal light indicates that the gate is moving 
and a light barrier monitors vehicles driving through. If something passes though 
the light barrier during closing, the system opens the gate again. 

If the system is switched on and the emergency stop button is not pressed, it is 
possible to open or close the gate by means of a brief pulse on the key 
switch/receiver of a remote control. In addition, you can control the gate using the 
buttons on the LOGO! or by means of the integrated web server (on a message 
text basis). 

The sliding gate is opened or closed until the corresponding end positions have 
been reached. 

Automatic closing mechanism 

On reaching the “Open” end position, closing starts automatically after 15s. You 
can parameterize the time by means of a switch-on delay. 

Path lighting 

Path lighting is activated by darkness (the astronomical clock) when the sliding 
gate is opened. When the sliding gate has reached the “Open” end position, the 
path lighting remains lighted for another 30s. You can parameterize the time by 
means of a switch-off delay. 

Parameters via message text 

In ongoing operation, you can parameterize the times for the automatic closing 
mechanism and afterglow of the path lighting using the LOGO! display or the web 
server (on a message text basis). 
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1.3 Components used 

This application example was created using the following hardware and software 
components:  

Table 1-1: Hardware and software components 

Component Number Article number Note 

LOGO! Soft 
Comfort V8.2 

1 6ED1058-0BA08-0YA1 You will find an upgrade to V8.2 
at: 
http://www.siemens.com/logo 

LOGO! 8.2  
12/24 RCE 

1 6ED1052-1MD08-0BA0 - 

LOGO!POWER  
24 V / 0.6 A 

1 6EP3330-6SB00-0AY0 - 

 

Note You need the components below to implement the sliding gate control. Due the 
wide range of different components that are available on the market, we will not 
list specific products: 

• Limit switch 

• Signal lamp 

• Light barrier 

• Power contactors 

• Coupling relays 

• Motor 

• Fuse, motor circuit-breaker 

• Buttons (key button, emergency OFF) 

 

The components must be compatible with the corresponding LOGO! 24V or 
230V variant that you are using. 

 

This application example consists of the following components:  

Table 1-2: Components of the application example 

Component File name Note 

Documentation 109755868_LOGO8_SlidingGate_en.pdf - 

LOGO! 8 
switching program 

109755868_LOGO8_SlidingGate_en.lsc LOGO! Soft Comfort V8.2 

 

 

http://www.siemens.com/logo
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2 Engineering  

2.1 Hardware structure  

 

Figure 2-1: Schematic structure 

LOGO! 12/24RCE

1 12 2 1 12 2

L+ M 1 32 4 5 76 8

1 2 3 4

x10

x11

Q1

Q2

K1

K2

24 V
L+

M

L1
L2
L3
N

Q1 Q2

M

K1 K2
LOGO! 

Power
+ -

L1 N

24 V

Control circuit

Load current circuit

S1 S2

S3 S4 S5 S6

P1 P2

 

Note Figure 2-1 shows a schematic diagram of the circuit structure. 
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Table 2-1: Assignment list 

Symbol LOGO! input/output Comment 

S1 Input I1 Switch, normally open contact; system ON 

S2 Input I2 EMERGENCY stop, normally closed contact 

S3 Input I3 (Key) button, remote control receiver; normally 
open contact 

S4 Input I4 Light barrier, normally open contact 

S5 Input I5 Limit switch, normally open contact; gate open: 

S6 Input I6 Limit switch, normally open contact; gate closed: 

Q1 Output Q1 Power contactor for the three-phase motor 

Q2 Output Q2 Power contactor for the three-phase motor 

K1 Output Q3 Coupling relay for the signal light 

K2 Output Q4 Coupling relay for the path lighting 

P1 - Signal light 

P2 - Path lighting 

M - Three-phase motor 

 

Note In the case of a LOGO! with relay outputs, coupling relays K1 and K2 are 
optional and are intended to save the integrated LOGO! relays. 

In the case of a LOGO! with transistor outputs, you must use coupling relays or 
contactors. 
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2.2 Switching program 

The illustration below shows the finished program for controlling a sliding gate 
using a reversing contactor circuit. We will go into the details of the individual 
program parts 1-7 below. To get a better understanding of the circuit, use 
simulation mode in LOGO! Soft Comfort. 

Figure 2-2 

1

2

3

4

5

6

7

 

1. You set or reset the latching relay by means of a brief pulse at input I1 or flag 
M1, or by pressing the ► cursor key on the LOGO! On setting, the rising edge 
is used to set the signal to open the gate. On resetting, the falling edge is used 
to set the signal to closed the gate. 
Flag M1 is used as the interface with the controller via a user-defined website.  

2. Switch-on delay for automatic closing of the gate after a defined time. The 
switch-on delay sets the signal for closing the gate if the limit switch at input I5 
is activated for the parameterized time. 

3. Circuit for opening the gate. 
The signals below set the relay by logical ORing: 

• Pulse for opening from the program part (1) 

• Activated light barrier at input I4 and gate not closed 

The signals below reset the relay by logical ORing: 

• 0 signal at input I1 (system OFF) 

• Activated EMERGENCY OFF at input I2 

• Pulse for closing from the program part (1) 

• Active limit switch at input I5 (gate open) 

• 1 signal for automatic closing from the program part (2) 

• Activated output Q2 (closing) from the program part (4) 
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4. Circuit for closing the gate. 
The signals below set the relay by logical ORing: 

• Pulse for closing from the program part (1) 

• 1 signal for automatic closing from the program part (2) 

The signals below reset the relay by logical ORing: 

• 0 signal at input I1 (system OFF) 

• Activated EMERGENCY OFF at input I2 

• Pulse for opening from the program part (1) 

• Active limit switch at input I6 (gate closed) 

• Activated light barrier at input I4 

• Activated output Q1 (opening) from the program part (3) 

5. Circuit for controlling the path lighting at output Q4. The astronomical clock 
prevents the lighting from being switched on during daylight hours. Path 
lighting is switched on after the sun goes down if the gate opens and remains 
switched on until the switch-off delay time has expired. The time starts as soon 
as output Q1 is no longer active (gate is open or closes again). 

6. Pulse encoder for controlling the signal light at output Q3. The pulse encoder is 
activated when the gate opens or closes.  

7. A message text showing the times that can be set for automatic closing of the 
gate and the duration of afterglowing of the path lighting. This makes it 
possible to conveniently carry out parameterization at runtime using the LOGO! 
display or the integrated web server (default web page). 

 

Note You can get a functional description of the circuit as a comment on the switching 
program in LOGO! Soft Comfort under “File> Properties > Comment”" or, 
alternatively under “Tools > Options > Comment”. 

You can find the designations of the inputs and outputs in LOGO! Soft Comfort 
under “File > Properties > I/O Names”. 

Hint: Under “Extras" > "Options" > “Print”, select the "Comment" check box to 
print the function description together with the program. 
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2.3 Commissioning 

Carry out the steps below to commission the LOGO! and the supplied switching 
program: 

1. Connect the LOGO! and all of the other components of the sliding gate control 
according to the hardware configuration (see see chapter 2.1). 

2. Switch on the supply voltage of the LOGO! 

3. Set the time of day and date of the LOGO! correctly. 
Description in the LOGO! 8 manual: 
https://support.industry.siemens.com/cs/mdm/109741041?c=86268056075&lc=en-WW 

4. Configure the network settings on the LOGO!, e.g.: IP address 192.168.0.3; 
subnet mask 255.255.255.0. 
Description in the LOGO! 8 manual: 
https://support.industry.siemens.com/cs/mdm/109741041?c=98458459403&lc=en-WW 

5. Use an Ethernet cable to connect the programming unit on which LOGO! Soft 
Comfort V8.2 is installed to the LOGO! Make sure that the programming unit is 
located on the same subnetwork as the LOGO! 

6. Open the supplied LOGO! switching program 
"109755868_LOGO8_SlidingGate_de.lsc" on your programming unit. 

7. Under “File > Properties > Offline Settings > General”, make the IP settings 
according to the configuration from step 3. Click on OK to close the window 

 

8. Open the “Options > Access Control” menu item. Use the interface of your 
programming unit to connect to LOGO! by clicking on "OK". 

 

https://support.industry.siemens.com/cs/ww/de/view/109741041/86268056075
https://support.industry.siemens.com/cs/ww/de/view/109741041/98458459403
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Select the “Allow Web Server Access” checkbox and enter a new password. 
Click on “Apply” to accept the settings and close the window by clicking “OK”. 

n the switching program, double-click to open the block properties of the 
astronomical clock [B019 Astrotimer]. 

 

 

Parameterize the astronomical clock with the latitude and longitude of the 
location at which you installed the LOGO! You can store the user-defined 
location using any name you like. Click on “OK” to close the properties dialog. 
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9. Optionally: In the block properties of block [B012 time aut. CLOSED], 
parameterize the time for the automatic closing mechanism and parameterize 
the time for path lighting afterglow in the block properties of block 
[B020 afterglow]. 

10. Click on the “PC -> LOGO!” icon to load the switching program into LOGO! 

 

11. Select the interface of your programming unit and click on “OK” to start the 
transfer. Confirm all of the dialogs below until loading has been completed and 
the LOGO! has entered “RUN” operating mode. 
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2.4 Operation 

In addition to controlling the gate using connected buttons and switches, you can 
also control it using the buttons on the LOGO! or by means of the web server. In 
addition, you can change the time parameters in ongoing operation. 

2.4.1 Web server 

Requirements 

• Your device (PC, tablet, etc.) is connected to the LOGO! via a LAN or wifi3 

• Your device is located on the same sub-network as the LOGO! 

Operation 

1. In a web browser, enter the IP address of the LOGO! and load the page. 

2. Enter your web server password and log in. 

 

3. Navigate to the virtual view of LOGO! base module "LOGO! BM". 

 

                                                   
3 LOGO! must be connected to a wireless LAN router. 
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4. Click on one of the times to parameterize a new one. 

 

5. Tap "ESC" and then ► to open the sliding gate or to close it. 

2.4.2 LOGO! display 

Changing parameters 

1. Press the "ESC" button for at least one second to activate change mode. 
Change mode is activated when a parameter has a dark background. 

*aut. close 

after:     15:00s

*Pathway lighting

Afterglow:

30:00s

*open/close :ESC+ 

 

2. Use the ◄ or ► buttons to choose the relevant parameter and tap "OK" to 
change the selected parameter. 

*aut. close 

after:    15:00s

*Pathway lighting

Afterglow:

30:00s

*open/close:  ESC+ 

 

3. Change the parameter value using the ▲ and ▼ buttons. You use the ► 
button to get to the next digit of the parameter. 

*aut. close 

after:     25:00s

*Pathway lighting

Afterglow:

30:00s

*open/close:  ESC+ 

 

4. Tap "OK" to confirm your changes and tap “ESC” to exit change mode". 

Operating the gate 

To open or close the sliding gate using the LOGO! display, press the "ESC" and 
"►" buttons on the LOGO! at the same time. 



3 Appendix 

 

LOGO! 8 - Sliding gate 
Entry ID: 109755868,    V1.1,    03/2019   16 
 

©
 S

ie
m

e
n
s
 A

G
 2

0
1
9
 A

ll 
ri

g
h
ts

 r
e
s
e
rv

e
d
 

3 Appendix 

3.1 Service and Support 

Industry Online Support 

Do you have any questions or need assistance?  

Siemens Industry Online Support offers round the clock access to our entire 
service and support know-how and portfolio. 

The Industry Online Support is the central address for information about our 
products, solutions and services. Product information, manuals, downloads, FAQs, 
application examples and videos – all information is accessible with just a few 
mouse clicks: support.industry.siemens.com 

SITRAIN – Training for Industry 

We support you with our globally available training courses for industry with 
practical experience, innovative learning methods and a concept that’s tailored to 
the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their 
locations and dates, refer to our web page: www.siemens.com/sitrain 

Industry Online Support app 

You will receive optimum support wherever you are with the "Siemens Industry 
Online Support" app. The app is available for Apple iOS, Android and Windows 
Phone: https://support.industry.siemens.com/cs/ww/en/sc/2067 

3.2 Links and Literature 

Table 3-1: Links and Literature 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to the entry page for the application example  

https://support.industry.siemens.com/cs/ww/en/view/109755868 

\3\ LOGO! 8 Manual, 11/2017 Edition 
https://support.industry.siemens.com/cs/ww/en/view/109741041 

\4\ LOGO! Soft Comfort online help 

https://support.industry.siemens.com/cs/ww/en/view/100782807 

\5\ LOGO! application examples 

https://support.industry.siemens.com/cs/ww/en/ps/13617/ae 

3.3 Change documentation 

Table 3-2: Change documentation 

Version Date Change 

V1.0 03/2018  First edition 

V1.1 03/2019 Textual adjustments 

 

https://support.industry.siemens.com/
https://www.siemens.com/sitrain
https://support.industry.siemens.com/cs/ww/en/sc/2067
https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/en/view/109755868
https://support.industry.siemens.com/cs/ww/en/view/109741041
https://support.industry.siemens.com/cs/ww/en/view/100782807
https://support.industry.siemens.com/cs/ww/en/ps/13617/ae
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